Osuma.fi:ssä epäonnistuneita hakuja
Incident Report for Fonecta WEB
Resolved
This incident has been resolved.
Posted Nov 19, 2013 - 15:31 EET
Investigating
Osa Osuma.fi:n hauista epäonnistuu tällä hetkellä. Syy on tutkinnassa.
Posted Nov 17, 2013 - 21:29 EET
This incident affected: Fonecta.fi and Fonecta Caller.