Caller alhaalla

Incident Report for Fonecta WEB

Resolved

Palvelinpään katko saatu korjattua.
Posted Mar 28, 2014 - 09:42 EET

Investigating

We are currently investigating this issue.
Posted Mar 28, 2014 - 09:25 EET